Kommunauty
Connexion
Inscription

Problème pour afficher une image


Alexou Messages : 2507

Bon premier problème, je le poste à la suite, ou dans un nouveau sujet? (au pire, un ptit modo va s'en charger.)

Voilà donc je commence par créer le design de mon site, mais quand je met une bannière, elle apparait pas.

J'ai taper:

<img src="&#46;&#46;&#46;/simpsons/enter" alt="banniere"/>

Le code se trouvant dans le dossier sitecode

L'image se trouvant dans le dossier sitesimpsons

J'ai donc taper ... pour allez au dossier parent, simpsons pour allez dans le dossier simpsons, suivie du nom de l'image, et je vois que banniere, donc l'image a un problème.

C'est sûrement le code, mais je vois pas l'erreur.

lundi 1 juin 2009

SiMax Messages : 7572

C'est pas .../ mais ../ pour remonter d'un répertoire

lundi 1 juin 2009

Alexou Messages : 2507

Ah ok merci

EDIT: marche pô''

lundi 1 juin 2009

SiMax Messages : 7572

Donne ton nouveau code voir

lundi 1 juin 2009

Alexou Messages : 2507
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1&#46;0 Strict//EN" "http&#58;//www&#46;w3&#46;org/TR/xhtml1/DTD/xhtml1-strict&#46;dtd">
<html xmlns="http&#58;//www&#46;w3&#46;org/1999/xhtml" xml&#58;lang="fr" >
   <head>
       <title>Bienvenue sur mon site !</title>
       <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
   <link rel="stylesheet" media="screen" type="text/css" title="Design" href="design&#46;css" />
   </head>
   <body>
   
   <div id="en_tete">
   <!-- Ici on mettra la bannière -->
   <p><img src="&#46;&#46;/simpsons/enter" alt="banniere"/>
   </p>
   <h1> Bienvenue sur SimpsonsLand </h1>
</div>
 
<div id="menu">
   <!-- Ici on mettra le menu -->
</div>
 
<div id="corps">
   <!-- Ici on mettra le contenu principal de la page (tout le texte quoi) -->
</div>
 
<div id="pied_de_page">
   <!-- Enfin, on mettra en bas de la page le nom de l'auteur, un copyright&#46;&#46;&#46; -->
</div>

       
   </body>
</html>
lundi 1 juin 2009

SiMax Messages : 7572

T'as pas d'extension sur ton image ! ../simpsons/enter

Une image est forcément en .png .gif etc. Voir => <a class="postlink" href="http://www.kommunauty.fr/article-223-les-formats-extensions-des-images" target="_blank">http://www.kommunauty.fr/article-223-le ... des-images</a>

lundi 1 juin 2009

Alexou Messages : 2507

Ah ok, je savais pas qu'il fallait mettre les extensions.

   <p><img src="&#46;&#46;/simpsons/entrer&#46;JPEG" alt="banniere"/>
   </p>

Et ça marche pas lol

lundi 1 juin 2009

Toms Messages : 16

Dans ton dossier est ce que le "enter" a une extension car ce n'est pas en rajoutant une extension dans le code html que sa va marcher il faut que le fichier que tu appel en l'occurence "enter" dois avoir une extension.

Ton image quand tu l'as crée tu l'as enregistré en quel format ?

Png,gif,jpg...?

lundi 1 juin 2009

Alexou Messages : 2507

jpeg

lundi 1 juin 2009

Toms Messages : 16

Ok,essaye de ne pas mettre jpeg en majuscule.

dans ton code html

lundi 1 juin 2009

Page suivante »