Kommunauty
Connexion
Inscription

Hover sur une image


Mizur Messages : 6617

Moi j'ai l'impression que t'as des trucs dans ta page qui empechent que ça marche, le span c'est pas évident à gérer.

lundi 26 mars 2012

Yopopo Messages : 28

J'ai essayé sur chrome, firefox et internet explorer mais le bouton ne veut toujours pas se changer au passage de la souris : http://very-zatchbell.com/zarno/ peut-être que mon code n'est pas bon, je vous laisse vérifier.

lundi 26 mars 2012

Warranty Messages : 391

Le code HTML actuel des boutons de ton site sont:

<li class="none">
<span class="amv_hover">
     <a href="amv.php" title="AMVs">
         <img src="styles/design/amv.jpg" alt="AMVs" />
        </a>
    </span>
</li>

Il faut que tu les modifies en:

<li class="none">
<a class="amv_hover" href="amv.php" title="AMVs"></a>
</li>

Est le code CSS:

.amv_hover
{
   display: block;
   width: 100px;
   height: 27px;
   background-image:url('styles/design/amv.jpg');
}

.amv_hover:hover
{
   background-image:url('styles/design/amv_hover.jpg');
}

Logiquement cela devrait fonctionné

lundi 26 mars 2012

Yopopo Messages : 28

Quand on passe la souris dessus on voit qu'il y a un lien mais les images ne s'affichent pas. :o:

lundi 26 mars 2012

Warranty Messages : 391

Voilà

.amv_hover
{
   display: block;
   width: 100px;
   height: 27px;
   background-image:url('../styles/design/amv.jpg');
}

.amv_hover:hover
{
   background-image:url('../styles/design/amv_hover.jpg');
}
lundi 26 mars 2012

Yopopo Messages : 28

Génial ça fonctionne enfin, merci beaucoup !

lundi 26 mars 2012

Warranty Messages : 391

Mais de rien nous sommes la pour ça

lundi 26 mars 2012

Répondre Pour répondre, tu dois d'abord t'inscrire rapidement sur Kommunauty. Rejoins-nous vite !